Enterprise 1 customers unable to connect to OBeer

Incident Report for OBeer

Postmortem

Summary:

On January 5th, 2024, users in the Enterprise 1 environment experienced intermittent trouble connecting to the OBeer application between 1:50 PM and 3:30 PM MST. The outage was caused by a malfunction in the Connection Broker component. We successfully restored access by restarting the service. To prevent similar incidents in the future, we are implementing additional redundancy measures.

Timeline:

  • 1:50 PM MST: Enterprise 1 users begin reporting issues connecting to the application.
  • 2:12 PM MST: Engineering team begins investigating the issue.
  • 3:02 PM MST: Investigation identifies the Connection Broker as the source of the problem.
  • 3:15 PM MST: The Connection Broker is restarted.
  • 3:30 PM MST: Users regained full access to the application.

Root Cause:

The outage was caused by an internal malfunction within the Connection Broker component. The specific issue was due to an issue with a windows component, and was

Corrective Actions:

  • Restart of the Connection Broker: This resolved the immediate issue and restored access to the application.
  • Increased Redundancy: To prevent similar incidents in the future, we are implementing the following measures:

    • Load Balancing: We are enabling load balancing for the Connection Broker to distribute traffic across multiple instances and avoid a single point of failure.
    • Second Connection Broker: We are adding a second Connection Broker to further increase redundancy and provide failover capabilities.
Posted Jan 16, 2024 - 12:34 MST

Resolved

We've monitored and seen no further issues with connections. We'll continue investigating the cause of the issue, and will post a postmortem when our investigation is concluded.
Posted Jan 05, 2024 - 16:50 MST

Monitoring

Connections are confirmed succeeding for all affected customers. We're continuing to monitor for any further issues.
Posted Jan 05, 2024 - 15:51 MST

Identified

We've identified a potential cause and have done some remediation. Connections are succeeding, but we are working to confirm that it's operational for everyone.
Posted Jan 05, 2024 - 15:31 MST

Update

We're continuing to investigate the issue.
Posted Jan 05, 2024 - 15:25 MST

Investigating

We have received reports from a customer on Enterprise 1 of difficulty connecting to OBeer. We are investigating and will continue to update this incident.
Posted Jan 05, 2024 - 14:07 MST
This incident affected: SAP Business One.