Users in the OnDemand environment are unable to connect

Incident Report for OBeer

Postmortem

Summary:

On September 10th, 2024, users in the OnDemand environment were receiving errors when connecting to the OBeer application between 1:15 PM and 2:25 PM MST. The outage was caused by a malfunction in the Domain Controller. We successfully restored access by restarting the service. To prevent similar incidents in the future, we are implementing additional detection measures.

Timeline:

  • 1:15 PM MST: OnDemand users begin reporting issues connecting to the application.
  • 2:23 PM MST: The domain controller is identified as the source of the problem
  • 2:25 PM MST: The domain controller is restarted. Users are confirmed to be able to connect.
  • 2:45 PM MST: All reported issues are confirmed resolved.

Root Cause:

The outage was caused by an issue with the DNS resolution function of the Domain Controller, which prevented the domain from being contacted from external connections. A restart fixed the issue.

Additional Remediation:

  • To help catch and prevent future issues, we added some monitoring to the Domain Controller:

    • DNS service monitoring
    • DNS response time monitoring.
Posted Sep 16, 2024 - 12:30 MDT

Resolved

We have watched and confirmed service is restored and everything is functioning normally.

We will review the issue and provide a post-mortem within 5 business days.
Posted Sep 10, 2024 - 14:47 MDT

Update

We are continuing to monitor for any further issues.
Posted Sep 10, 2024 - 14:27 MDT

Monitoring

A fix has been implemented and we are monitoring the results. Users should now be able to log in.
Posted Sep 10, 2024 - 14:27 MDT

Investigating

We have received reports of customers being unable to login to our hosted SAP OnDemand environment. We are investigating and will continue to post updates to this incident.
Posted Sep 10, 2024 - 13:47 MDT
This incident affected: SAP Business One.